Announcement

Collapse
No announcement yet.

Mecha unresponsive

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • Mecha unresponsive

    Hi.
    This morning while i was shooting domes Mecha stopped working suddenly.
    I was in a residential area with many home wifi lans around. Suddenly web interface stopped working and mecha was unresponsive. Mecha was on and wifi working.
    So i shutted down mecha and restart. It worked again and then stopped again.
    Instead preset phisical buttons on mecha body were working correctly.

    It has never happened before. I usually shot in very isolated places, thirst time in a residential area.

    Is there any way to recover something like a log in order to analize the problem?

    Thanks
    Raf

  • #2
    Hi, there is no log yet.

    Is good to know if when apparently UI stopped working instead of time top-right you see "waiting.." and the period of seconds waiting increasing.
    if that increase it means the UI is working OK and is executed by the phone, only it lost connection for some reasons (the number of channels available to Wi-Fi is limited and channels can overlap and that can cause lost of connection, thus the next step which is to see if connection to MECHA Wi-Fi looks OK, mean the phone is still connected to MECHA Wi-Fi.

    If you can test again in similar environment and have enough experience with MECHA try switching the roles, setting an hot spot to your phone with a password, and connect MECHA to phone hot spot, the MECHA address IP will depend on your phone but you can find it (will be more easy to find it in the next FW updates) at home and test at home first
    If your phone doesn't show the IP of clients connected to its hot spot you can enter this code when MECHA is connected to phone hot spot.
    Using MECHA's buttons, enter
    323<
    that will show the full IP address on MECHA LEDs,
    you may need to do this only once
    Click image for larger version  Name:	fetch?id=29319&amp;d=1548168340.png Views:	3 Size:	2.5 KB ID:	30262

    e.g. on my android phone it is
    192.168.43.130

    So the scenario will be

    at home
    1) set the hot spot on on your phone with Wi-Fi and pass but not set active yet.
    2) connect phone to MECHA as usual
    3) select Connect to Wi-Fi in UI entering Wi-fi name and pass from point 1) then you'll see the LEDs scanning up-down
    4) activate the hot spot on phone, then you'll see the LEDs stop scanning and MECHA will be connected to your phone.
    5 a) if you can see the IP of the newly connected client to phone hot spot write it down or access that address like
    http://192.168.43.130/ring
    or, if you can't see it in your phone
    5 b) press [3] then [2] then [3] then [<] buttons of MECHA and note the IP address sown via LEDs according with above table
    and access it via, say, http://192.168.43.130/ring

    on field
    6) Start the hot spot on phone
    7) power ON MECHA as usual
    8) and access MECHA interface via, say, http://192.168.43.130/ring as was at home, you may have it in browser history

    Test if there are problems now when the roles are switched regarding Wi-Fi serving.

    For sure these requires some advanced knowledge of phone and MECHA and maybe is better to have as back-up the pano session assigned to buttons, just in case, then you can repeat the pano in each point, and ignore all the complicated stuff above and under.

    If you suspect malicious scanning of Wi-Fi or want to prevent it, or simply is a too noisy Wi-Fi area you panning in, you can go as far as disabling Wi-Fi at start.
    Here are the buttons you can press at start, when MECHA LEDs shows - = - = - = - =

    1) press [1] for 3 seconds -> AP mode with 192.168.8.1 address for interface.
    2) press [2] for 3 seconds -> STA mode and will try 1 minute to connect to last Wi-Fi, if doesn't succeeds, it reverts to AP mode.
    3) press [3] for 3 seconds -> Wi-Fi reset then will try to connect to M-123ABC if is available and perform an update if is available, or AP mode if M-123ABC isn't available (123ABC is MECHA's ID)
    4) no button pressed -> will try enter in last mode or AP.
    5) press [>] short is the same as (4) but without waiting for -=-=-=-= to finish, for quick use of MECHA
    6) press [<] for 3 seconds -> Wi-Fi turns OFF. Will be ON when MECHA is powered again.


    Dorin
    1. Mecha it possible.
    2. Mecha it easy.
    3. ..

    Comment


    • #3
      Sorry to hear the issue. I know some people may use wifi hacking tool in order to use others wi-fi free of charge. The 12345678 password is too easy to hack.
      in the 192.168.8.1/new page, there is a Config* button. Login with
      User: admin
      PW: Mecha
      Change the password to a more sophisticated one.


      Nick
      Fanotec
      We listen. We try harder.

      Comment


      • #4
        Originally posted by DorinDXN View Post
        Is good to know if when apparently UI stopped working instead of time top-right you see "waiting.." and the period of seconds waiting increasing.
        if that increase it means the UI is working OK and is executed by the phone, only it lost connection for some reasons (the number of channels available to Wi-Fi is limited and channels can overlap and that can cause lost of connection, thus the next step which is to see if connection to MECHA Wi-Fi looks OK, mean the phone is still connected to MECHA Wi-Fi.
        Dorin
        It happened as decribed above. Waiting message and counter increasing.
        The first thing i thought was channel overlapping or disturbing, so may be this the root cause.

        By the way i don't get how "role reversing" trick may solve the problem. What's the difference about hotspot locally on phone and on mecha if i can't select channels?

        Thanks
        Raf

        Comment


        • #5
          Is good to know if reversing the role will fix the problem, there are lots of differences between two modes apart from channel overlapping.

          Dorin
          1. Mecha it possible.
          2. Mecha it easy.
          3. ..

          Comment


          • #6
            When you connect MECHA in AP mode by wi-fi, MECHA is also accepts connection from other devices.
            When your phone is the hotspot and MECHA in Station mode, it won't accept connection from other devices. Less chance of attack.
            your phone should have better channel management too.

            Nick
            Fanotec
            We listen. We try harder.

            Comment


            • #7
              Unfortunately it happened again with no other Wi-Fi around. Didnt tried the iphone hotspot method. I nver had such disconnections since latest firmware. I canít say if itís iphone or mecha related. For sure this time there was no other Wi-Fi than mecha network.
              Last edited by RaffaGa; 1 week ago.

              Comment


              • #8
                Next step will be to try using another phone/notebook/tablet to see if is indeed MECHA in question, no changes were made to affect stability in latest FW,

                Then, if is indeed MECHA, we'll look for other steps.

                Dorin
                1. Mecha it possible.
                2. Mecha it easy.
                3. ..

                Comment


                • #9
                  Originally posted by RaffaGa View Post
                  Unfortunately it happened again with no other Wi-Fi around. Didnt tried the iphone hotspot method. I nver had such disconnections since latest firmware. I canít say if itís iphone or mecha related. For sure this time there was no other Wi-Fi than mecha network.
                  Have you changes the wifi password to a stronger one? It can be just a few second if someone tries to connect to MECHA and disrupt your connection.
                  Also what is the temperature like? Is MECHA too hot to touch for long?

                  Besides, some phone will attempt to switch to other network if it finds MECHA has no internet access or its signal being week. In this regard, letting MECHA connect to a hotspot on your phone is beneficial.

                  As a general stability test, you can set MECHA in interval mode and have it run for as long as battery support.
                  Last edited by nick fan; 1 week ago.
                  Fanotec
                  We listen. We try harder.

                  Comment


                  • #10
                    Have you changes the wifi password to a stronger one? It can be just a few second if someone tries to connect to MECHA and disrupt your connection.
                    Yes i did. But it's not a password hacking problem because i was completely alone on a peek of a mountain.

                    Also what is the temperature like? Is MECHA too hot to touch for long?
                    No, it was about 15įC.

                    Besides, some phone will attempt to switch to other network if it finds MECHA has no internet access or its signal being week. In this regard, letting MECHA connect to a hotspot on your phone is beneficial.
                    As told my iPhone had no issues before. I can't say at this point if it could be an issue releted to the latest ios released. I'll test on an android phone next-time.


                    As a general stability test, you can set MECHA in interval mode and have it run for as long as battery support
                    As a second test i'll try this too.

                    By tthe way, the solution is always to turn off mecha and then turn it on again.

                    Comment


                    • #11
                      peak of a mountain?

                      Some mountains have big RF receivers and broadcasting towers. It may have some effect.

                      When MECHA disconnect, can you reconnect by toggling wifi on/off on your phone?
                      When you see this problem, you can try resetting MECHA with long press button 3 after power up with LED flashing.
                      You will hear 6 beeps. It should wifi out something in memory and become fresh again.

                      Nick
                      Fanotec
                      We listen. We try harder.

                      Comment


                      • #12
                        Originally posted by nick fan View Post
                        peak of a mountain?

                        Some mountains have big RF receivers and broadcasting towers. It may have some effect.

                        When MECHA disconnect, can you reconnect by toggling wifi on/off on your phone?
                        When you see this problem, you can try resetting MECHA with long press button 3 after power up with LED flashing.
                        You will hear 6 beeps. It should wifi out something in memory and become fresh again.

                        Nick
                        I was at 3000 meters. There were no antennas around. Zero signal all the way,
                        Resetting wifi on phone doesn't work. I have to manually turn off/on mecha with power button.

                        I will try to flush mecha with button 3 also.

                        Thanks
                        Raf

                        Comment


                        • #13
                          I'll stress a MECHA with an iPhone 4 for couple of days, will be a FW update next week, If I'll find some issue needed to be corrected, I'll let you know, and will be fixed in next update, of course.

                          Dorin

                          1. Mecha it possible.
                          2. Mecha it easy.
                          3. ..

                          Comment


                          • #14
                            Just want to let you know that I found a bug which is somehow related, though might not manifest in your case, but is related, and is very old.

                            Ring/Row have a pooling interval, how often data is requested and received from MECHA, that is 0.5 second at default, at loading the page, then it can be changed via a drop-down list,
                            that change I found that is not working currently, again, the value should remain 0.5 sec if not changed, but if is changed it became long, around 10 seconds , I fixed and will be published in next FW update, but I'll search for more bugs, will not be published just yet but very soon.

                            If you changed the pooling interval from @0.5 s to any value even back to 0.5 s that can cause a 10 seconds lag in UI update, but commands should work fast, only the feedback is not as often as it should.

                            Is somehow related and is possible to have some side effects in your case, very unlikely but possible.

                            Simple workaround to this is page refresh/reload in browser, that should also tell if is the cause for non-responsiveness in your particular use.

                            Dorin
                            1. Mecha it possible.
                            2. Mecha it easy.
                            3. ..

                            Comment

                            Working...
                            X