problems with 57 frame pano please help.

Welcome to Nodal Ninja Forum

+ Reply to Thread
Results 1 to 8 of 8

Thread: problems with 57 frame pano please help.

Share/Bookmark
  1. problems with 57 frame pano please help.

    #1
    Unhappy

    I recently returned from the Baltoro Glacier in northern Pakistan with a 360' panorama, a very small section of which is available here.

    As you can tell there is a lot of 'fanning' throughout the image. Here's how I took the picture.

    NN5 with sturdy Feisol tripod.
    Spirit level on the hotshoe.
    Canon 5DII and 50mm lens.
    Shot in RAW using a remote control.
    Shot in manual at 400th of a second.
    No vignetting in separate images.
    No auto iso
    No polarizer left on by mistake.

    When I process the picture in Adobe CS5 I get this 'fanning', however, when I process it in Ptgui I get other lesser issues, with Ptgui I get what I could best describe as areas of poor join. I've tried processing the pano' in three sections with a left, middle and right then joining them up later but still no improvement.

    I then took three images that showed a blatant fault in Ptgui, I took these three images and processed them in CS5 and they were fine. So I must be doing something wrong with the software. Yet I've done many pano's before without this issue - though never a 360'.

    I wonder if I might be over over lapping the shots as I tend to overlap 50%


    Any thoughts would be appreciated,

    Many thanks
    Attached Thumbnails Attached Thumbnails Click image for larger version

Name:	360_Panorama-Section1.jpg
Views:	79
Size:	30.5 KB
ID:	107  
  2. #2
    Users Country Flag
    Join Date: Apr 2008
    Location: Hong Kong
    Posts: 2,437

    maybe manually entering yaw and pitch values for each frame will help. The images of sky is featureless for control point generation.

    nick



    Fanotec
    We listen. We try harder.
  3. #3
    Users Country Flag
    Join Date: Aug 2008
    Location: Netherlands
    Posts: 1,741

    Hi,

    Would be nice if you could send the images so we can test them for you. May be Autopano Giga helps cause it stitches blue skies taking picture by picture.

    Heinz
    Last edited by hindenhaag; 09-07-2010 at 10:10 PM.
  4. #4

    57 images seems an odd choice for a 360 panorama; was this really 3 rows of 19 shots? 50% overlap isn't excessive, but not really necessary. The alignment problems in PTGui might be due to control points automatically placed on the moving clouds. Delete all points on clouds. In places, you may have more than 50% overlap, so it's a good idea to remove all points between non-neighbouring images such as 0 and 2, 1 and 3 etc. Otherwise, ensure that you do have points between all pairs of neighbouring images.

    There seem to be exposure variations between shots. You say you used manual at a 400th, but fail to mention the f/no and confirm that this was also fixed throughout. Exposure variations can arise during RAW processing: take care to avoid all RAW auto settings such as auto exposure and auto white balance and apply exactly the same conversion settings to all the images. Another possibility is that the light was varying as clouds passed over the sun.

    PTGui Pro will handle minor exposure variations very well via the automatic exposure and colour correction options on the Exposure/HDR tab in Advanced mode. You will not get hard edges between images in the final blended panorama such as can be seen in your sample image.

    John
  5. #5

    Thanks to everyone's help.

    Thank you for your responses to my panorama problem, I have discovered the reason why it did not work correctly in CS5, the blending process did not complete because of in-sufficient scratch disk space the file being over 5gb. Luckily I was able to use a 2 tb drive for this and that allowed the blending process to complete. The resulting panorama is now extremely good and I am satisfied with it, though there are some areas of blue sky where there seems to be a slight density shift, but not so much to be troublesome.

    Using Ptgui, though the blending process works satisfactory it leaves some unusual artefacts, particularly round clouds, John Houghton's reply suggesting removing control points from the sky areas and I'm going to try this later today.

    Andrew (will post the images on here soon)
  6. #6

    I should remember to point out the file was 5gb prior to flattening (CS5) the image. All shots were taken at f22.
  7. #7

    You might try using the alternative blender Smartblend with PTGui. This tries to route seam lines around the edges of objects and is often very successful in hiding stitching errors due to moving objects or parallax. It can be downloaded from http://wiki.panotools.org/SmartBlend, and needs to be registered in PTgui via Tools->Options->Plugins. Specify command line parameters as -w -MinSize 32. Select Smartblend on the Create Panorama tab in the blending option.

    John
  8. #8
    Users Country Flag
    Join Date: Aug 2008
    Location: Netherlands
    Posts: 1,741

    I was stuck with this fault as well once upon a time. In PTGui >preferences >Folders & Files you can select one or more folders for temporary files. Sometimes it is asking 15 Gb or more for temporary files. Depends on your pano.

    Heinz
+ Reply to Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts