8mm Sigma for Canon (Canon 7D in my case) NPP Question

Welcome to Nodal Ninja Forum

+ Reply to Thread
Page 1 of 2 1 2 LastLast
Results 1 to 15 of 16

Thread: 8mm Sigma for Canon (Canon 7D in my case) NPP Question

Share/Bookmark
  1. 8mm Sigma for Canon (Canon 7D in my case) NPP Question

    #1
    Question

    I originally purchased the Sigma 4.5mm Canon lens made for the APS-C sensor for my Canon 7D with the corresponding ring for the R1 head. I got excellent results that stitched well in Easypano Panoweaver, PTGui and AutoDesk Stitcher (aka. Realviz) shooting 3 horizontal images at +5 degree tilt. I'm new to this kind of photography, so I sampled all the main stitching softwares and found them easy to use and provided good results.

    Unfortunately I had not realized that even with an 18million megapixel sensor, the best resolution for the final pano is only 5624x2812 pixels due to the fact that most of the sensor is not exposed to the spherhical image produced by the 4.5mm lens

    So I switched to the 8mm Sigma lens and the corresponding R1 Ring and now have a final spherical pano resolution of over 10,000x5000 pixels and I shoot 4 horizontal images instead of 3. (My many thanks to Nodal Ninja and Henry's photography for allowing me to exchange the gear).

    However I am having very bad alignment problems. I mounted the lens in the R1 head following the directions as before, but none of the above softwares can perform and acceptable stitch.

    Documentation states that NPP point is at 1.95cm for +5 degrees for the 8mm Sigma - Canon lens . So I questioned if the NPP value was correct and did some tests aligning a tip of a lead pencil with a distant object while rotating the camera and my observations indicated a NPP point of 1.55cm. However my stitch results are still terrible.

    I would like to know if anyone else has had to use different NPP settings than indicated in the documentation, or are they considered good as gold? Is there a fundamental difference in how the software should be used with the new setup? Could the problem be with the lens? Or is the problem somewhere between the chair and the keyboard - me?

    Any feedback would be much appreciated.

    Cheers,
    -Rick.
  2. #2

    Quote Originally Posted by rickinmoz View Post
    Is there a fundamental difference in how the software should be used with the new setup? Could the problem be with the lens? Or is the problem somewhere between the chair and the keyboard - me?
    There's no fundemental difference in the way the 8mm images are stitched as compared to the 4.5mm images. The problem does quite likely lie between the chair and keyboard. But why are you taking 4 shots around rather than 3? The horizontal fov is 180 degrees, so there is ample overlap with 3 shots. 4 is not better. Even so, the 4 shots should stitch ok with a little care. It would help a lot if you could upload a set of (maybe half size) images somewhere, so that we might see if the images are in fact stitchable, and if not - why.

    John
  3. #3
    Users Country Flag badders's Avatar
    Join Date: Jan 2009
    Location: East Kilbride, Scotland
    Posts: 349

    Quote Originally Posted by rickinmoz View Post
    However I am having very bad alignment problems. I mounted the lens in the R1 head following the directions as before, but none of the above softwares can perform and acceptable stitch.
    This may be an obvious check - you HAVE removed the ring that holds the lens cap on, haven't you?......



    Badders
  4. Link to sample pictures

    #4

    Quote Originally Posted by John Houghton View Post
    There's no fundemental difference in the way the 8mm images are stitched as compared to the 4.5mm images. The problem does quite likely lie between the chair and keyboard. But why are you taking 4 shots around rather than 3? The horizontal fov is 180 degrees, so there is ample overlap with 3 shots. 4 is not better. Even so, the 4 shots should stitch ok with a little care. It would help a lot if you could upload a set of (maybe half size) images somewhere, so that we might see if the images are in fact stitchable, and if not - why.

    John
    Hi John,

    Thanks very much for the reply.

    I am shooting 4 shots around because there is not enough overlap with only 3. The canon 7D is not a full frame, and the 8mm lens with the APS-C sensor results in a cropped image. Here is a link to some of my images for download:

    http://www.zumodrive.com/share/6ZHhYjAwNz

    One folder contains 4 images at the 1.95 cm setting on the pano head as indicated in the Nodal Ninja documentation and the other folder has images taken at 1.55cm setting , which is the NPP point according to my tests I performed by rotating the camera while focusing on the tip of a lead pencil in the foreground with no shift in the background.

    There is a grid on the floor to help with creating control points in that area... the grid has thick lines 10cm apart and thin lines that are at 2cm apart. There is also a rectangular piece of paper placed between the pano head and the tripod to further help with visualizing misalignments.

    Thanks very much for offering to have a look at a sample of my images. I've tried moving the NPP point on the pano head at 1mm increments to see if I could minimize the sawtooth effect without much luck.

    Perhaps someone who is more experienced can tell me if my stitching problems are caused by parallax problems or because I am not calibrating the lens settings properly in PTGui.

    I also included some old images I have taken with the 4.5mm Sigma lens... although resolution is poor they stitch without a hitch!

    Thanks very much for any help,
    -Rick.
    Last edited by rickinmoz; 08-25-2010 at 10:59 AM.
  5. #5

    Rick, Sorry about the 7D confusion, I was obviously thinking it was fullframe like the D700. There isn't much difference between the two sets of images. Both stitched well enough, though the 15.5mm project optimized a little better than the 19.5mm one. I have put both project files at http://www.johnhpanos.com/rickpan.zip.

    John
  6. #6

    Thank-you so much for your time and help, much appreciated. Looking at the project files you sent, I learned the following:

    - I now know where to place crop circle for images produced by this lens (I didn't think I could include any of the non exposed frame area at the top and bottom without creating a hole in the zenith)
    - Confirmed the NPP point on rail at 15.5mm may really be more appropriate
    - Better know where to place contol points for a better stitch

    I think I was was spoiled by 4.5mm lens, since PTGui was able to stitch images from that lens consistently and automatically with no intervention from me placing control points manually. So I tried in vain to find a NPP point with the 8mm lens that would easily produce the same results.

    While waiting to hear back I continued to work on this and manually positioned over 100 control points evenly throughout all the image pairs... it took forever, but I also got a good result, but moving forward cannot afford to spend that much time on each panorama if I'm doing many of them. From studying the project files you sent, I'm guessing that you let PTGui place most of the control points and then manually placed a couple of control points in each image pair in the zenith and nadir areas? I think you got a great result, hopefully without too much extra fiddling.

    I thought that now that I have a template with proper lens parameters that PTGui would then be able to automatically stitch panoramas moving forward, but it seems that I will always have to manually place some control points to correct the Nadir and Zenith areas... is this a typical work flow?

    Even though with the 4.5mm lens wasted most of the sensor by producing circular images and low resolution panoramas, PTGui performed an excellent stitch without having to place control points in the zenith and nadir areas. I'm wondering if there is a reason why PTGui bunches them mostly in the middle, and is there a way to get it to place some in the zenith and nadir areas?)

    When you produced the panorama, did the pano head also look distorted in the nadir? Here's a link to what my pano head looks like with the 4.5mm lens vs the 8mm lens (It's not easy to see, but one of the three knobs on the easy leveller is kinda pointy instead of round in the 8mm):
    http://www.zumodrive.com/share/70NTYzk4ZW

    Do you know why this would be happening with the 8mm images? I have this problem no matter where I place the pano head NPP on the Ulitimate R1 Rail

    Hopefully moving forward when I no longer have a grid on the floor and a symmetrically tiled ceiling to help with finding corresponding matches for control points I won't have too much difficulty correcting the nadir and zenith areas.

    I'm off to try some more. Thanks for the help and steering me in the right direction.
    -Rick
  7. #7

    Rick, Alignment errors on the hardware immediately below the camera are not really anything to worry about. The floor is perfectly stitched and the tripod and panohead are going to be patched over with a nadir shot or cloned or whatever. The misalignments are caused by the variation in the apparent entrance pupil position, which varies with the angle of rays entering the lens. At the bottom of the image frame, light is entering the lens at close to 90 degrees to the optical axis, whereas at the horizontal level, the images join where the light is entering the lens at 45 degrees. Parallax cannot be perfectly eliminated for both of these cases simultaneously. Some compromise or sacrifice has to be accepted when adjusting the head. The R1 only has fore and aft adjustment, so there are limits to what can be done.

    John
  8. #8

    Quote Originally Posted by badders View Post
    This may be an obvious check - you HAVE removed the ring that holds the lens cap on, haven't you?......
    Interesting comment Andrew,

    Some time ago I had a set of a number of panoramas sent in because they weren't stitching well in PTGui and the problem was the reduced FoV caused by only the front part of the lens cap on a Sigma 8mm lens being taken off, leaving the cylindrical part on the lens, which could clearly be seen in the images.
    There was no possibility of a re-shoot because the images had been made at HDS Laser Scanner locations, but I eventually managed a reasonable result with a lot of manual import.
    A useful lesson learned, but I have written a note to remove all of the lens cap with a Sigma 8mm in our user guides as a result of this incident!

    Best regards, Hugh.
  9. #9
    Users Country Flag badders's Avatar
    Join Date: Jan 2009
    Location: East Kilbride, Scotland
    Posts: 349

    Quote Originally Posted by Hugh View Post
    A useful lesson learned, but I have written a note to remove all of the lens cap with a Sigma 8mm in our user guides as a result of this incident!
    I got this little tip from Bruce Cole my good friend at IPIX when I did exactly the same thing with the Sigma 8mm f/4 when IPIX released their 4 shot REALVIZ plugin. :blushing:



    Badders
  10. #10

    Hi John,

    That's good to know... I was worried that if I didn't get a good stitch in the nadir, this would cause problems later for using PTGui viewpoint correction. I'm glad to know I don't need to worry about the misalignments in nadir. Since the 4.5mm lens was able to produce a good stitch in the nadir, I then got deluded into thinking I should always expect this result.

    Now that I have created a good template, stitching the 4 shots together is effortless and I'm off to the races.

    I likely will be doing another stint with VSO which usually includes some travel to London and Harborne Hall in Birmingham... when I'm that way I'll have to call round and buy you a pint or two.

    Thanks for all the advice!

    -Rick.
    PS. If anyone reading this post also happens to find the information useful and would like to get the files for aforementioned downloads, if the links are no longer working then drop me a line at rlichtenauer@yahoo.ca and I will make the files available.
  11. #11

    Hi all,

    I just bought the Nodal Ninja R1 from Nodal Ninja Italy. Excellent services, less than 24 hours delivery !!!

    I bought with the R1, the dedicated stop plate for my Sigma 8mm mounted on a Canon 50D with a 5° vertical tilt in order to cover zenith with just 4 shoots horizontal..

    When I assemble the head, I could notice that with the stop plate, the settings was 16.5mm and not 19.5mm as indicated on the user manual. In fact there is a 3mm shift between since at 0° tilt angle, i have the same diference. I also did an alignment test making sure the object considered for alignment was situated at the seam of my shots (45° from the rotator click). With the 16.5 settings given by the stop plate, my shot are perfectly aligned (measurment done in Photo shop). with 19.5, I was a lttle bit off. I will give a try to 15.5mm.

    One thing I also noticed is that the only good scale to read the distance is the fix one. The other one where you have tighting screw is useless, almost 1mm of play depending how you push it.

    I will sugest my contact at Nodal £Nija in Italy to remove it since it is confusing. I read in this forum someone complaing about a difference between the two reading.

    I don't know if poeple from nodal ninja read this forum, but they should take a look at this inconstency between their manual and the stop plate, don't forget that most of the client choose Nodal nonja, because you don't have to find your NPP setting yourself ;)
  12. #12

    Hi Laurent,

    Thanks for the kind words! I was glad I managed to anticipate the shipping to let you play with your new toy before the weekend ;)

    Not sure if you're confusing something there: what I can say is that I've been using extensively the 1.95cm position with the Sigma 8mm Canon and the R1 tilted up at 5° and the alignmens is just perfect for 4 shots aorund in the seam area. The 1.65mm setting is good for the 7.5 tilt up position instead. Can you double check your settings and give me a feedback?

    Cheers,
    Mauro



    Mauro Contrafatto
    Customer Service Manager
    cs@nodalninja.com
  13. #13
    Users Country Flag
    Join Date: Apr 2008
    Location: Hong Kong
    Posts: 2,365

    Quote Originally Posted by Mauro Contrafatto View Post
    Hi Laurent,

    Thanks for the kind words! I was glad I managed to anticipate the shipping to let you play with your new toy before the weekend ;)

    Not sure if you're confusing something there: what I can say is that I've been using extensively the 1.95cm position with the Sigma 8mm Canon and the R1 tilted up at 5° and the alignmens is just perfect for 4 shots aorund in the seam area. The 1.65mm setting is good for the 7.5 tilt up position instead. Can you double check your settings and give me a feedback?
    Cheers,
    Mauro
    Some time ago, we updated the reference marks (3 lines) on the clamp of R1. Early batches of R1 has the marks at the middle of the clamp. NPP value is different when the clamp is installed in reverse direction. To remove this confusion, the later batches of R1 has the marks at the position alone the mid point of the mounting screws of the clamp. The NPP value is the same regardless of the orientations of the clamp. The difference between the old and new position is 2.5mm. The NPP values in the database are for the early batches. New clamps has a value -2.5mm from that on the database.
    The stop plates are not affected by change of marking positions. They should be within +/-0.5mm from actual value.



    Nick



    Fanotec
    We listen. We try harder.
  14. #14

    Thanks Mauro and Nick for your quick comments,

    Now it makes sence. So a reading of 16.5 instead of 19.5 is almost normal, I have the new clamp with the marking inbetween the two fixing screw, aligned with the brass pin.

    So the stop plate setting should be 17+/- 0.5. I have 16.5 and can confirm that the pictures are very well aligned. PTGUI is very happy with it and indicates an average distance of the control points arround 1.5. That is a good news that I can trust the stop plate, then my panohead get fully idioteproofed.

    Nick since the solution is known, I would sugest that you update the user manual with a comment concerning the shift in value for the new clamps. If I hadn't bought the stop plate, I would have been in trouble to understand why my good settings were different than the one in the manual. You should also remove the mark on the mobile part of the clamp, as I mentionned you never get the same reading on both side. Ones could think that there is an issue with the quality of your product which is too bad since I'm convinced this is just an amazing product!

    The only thing I miss now is a fixture to attach my flash.

    Kind regards,

    Laurent
    Last edited by Laurent; 08-31-2010 at 12:39 AM.
  15. #15
    Users Country Flag
    Join Date: Apr 2008
    Location: Hong Kong
    Posts: 2,365

    Quote Originally Posted by Laurent View Post
    Thanks Mauro and Nick for your quick comments,

    Now it makes sence. So a reading of 16.5 instead of 19.5 is almost normal, I have the new clamp with the marking inbetween the two fixing screw, aligned with the brass pin.

    So the stop plate setting should be 17+/- 0.5. I have 16.5 and can confirm that the pictures are very well aligned. PTGUI is very happy with it and indicates an average distance of the control points arround 1.5. That is a good news that I can trust the stop plate, then my panohead get fully idioteproofed.

    Nick since the solution is known, I would sugest that you update the user manual with a comment concerning the shift in value for the new clamps. If I hadn't bought the stop plate, I would have been in trouble to understand why my good settings were different than the one in the manual. You should also remove the mark on the mobile part of the clamp, as I mentionned you never get the same reading on both side. Ones could think that there is an issue with the quality of your product which is too bad since I'm convinced this is just an amazing product!

    The only thing I miss now is a fixture to attach my flash.

    Kind regards,

    Laurent
    Yes, I planned to update the manual and database. But all of a sudden I have been occupied by other stuff. People have been chasing me for new products. And I just moved my factory in late July. Busy like hell!
    Well, if a customer spend a few minutes to calibrate his/her pano head, he/she will get the right spot. If one manages to make a parallax free pano, he/she should trust his/her settings.


    NIck



    Fanotec
    We listen. We try harder.
+ Reply to Thread

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts