Possible NN3 settings problem

Welcome to Nodal Ninja Forum

+ Reply to Thread
Results 1 to 3 of 3

Thread: Possible NN3 settings problem

Share/Bookmark
  1. Possible NN3 settings problem

    #1

    Hello Everybody,

    I just got a NN3II and am really struggling a bit with the learning curve. I'm shooting a Nikon D80 with a sigma 8mm F3.5 EX DG and using PTgui as my stitching software.

    My main focus is to be able to stitch QTVRs to scan data collected with the Leica HDS 6000 and eventually maybe do some virtual tours for clients on the side. My main problem is that I have not yet mastered the stitching process. I have tried a few different methods as far as taking photos for pano conversion, but have yet to find it easy. really, my only successful pano is of the parking lot outside my office, and no one wants to see that. I have tried 2 basic work flows, one is to take 4 shots at 90 degrees, one zenith and one nadir. the second is to take 8 shots around at 45 degrees, one zenith and one nadir. I have noticed that the 8 shots seems to stitch much better because of more overlap, though the 4 shot method works fairly well. My biggest problem is that in PTgui my zenith shot always messes up the rest of the pano. If I remove it my pano lines up very well but I have a small hole in the top, if I leave the zenith in, there is a small bit of misalignment in the pano.
    finally my question. Because this is a reoccurring theme in all of the panos that I have tried, Is the misalignment caused by the zenith shot indicative of a poor set up between my camera and the NN3II, or is it something else that I am doing wrong?
    any help would be very much appreciated.


    Thanks in advance,
    Bill Wunderlich
  2. Re: Possible NN3 settings problem

    #2

    It may be that the parking lot panorama was more successful because things were generally further away from the camera, so parallax was less of a problem. You should be able to get pefectly good stitches by taking 4 shots around. Indeed, if you tilt the camera up a few degrees, you may be able to manage without a zenith shot, as there will be no hole to fill. Note that the optimum camera position on the upper rail would be different for 8 around and 4 around. One setting would not be correct for both. You should test for parallax at 4 shots around by one of the standard methods. E.g. http://www.johnhpanos.com/epcalib.htm .

    When you run the optimizer, you need to include the horizontal and vertical shift parameters (d & e) in the optimization. Also, be on the alert for an upside down zenith image, which is likely to result in stitching errors. You may have the camera's auto rotate sensor enabled, and this gives unreliable data when the camera points straight up or down. When you present the images to PTGui, they all should be in exactly the same orientation. E.g. all rotated by -90 degrees into portrait orientation from the native landscape orientation of the camera. It is all too easy to have the zenith rotated by +90 degrees, in which state it is in portrait orientation, but upside down with respect to the horizontal shots. Disabling the orientation sensor in the camera is a simple and effective way to avoid these problems.

    If you optimize the horizontal shots satisfactorilly and then add in the zenith shot, you can uncheck all the y,p,r parameters of the horizontal shots on the Optimizer tab (Advanced mode), and also uncheck the lens parameters. If you only optimize y,p,r of the zenith image to align it with the horizontal shots, then there is absolutely no possibility of the zenith shot "messing up the rest of the pano".

    John
  3. Re: Possible NN3 settings problem

    #3

    Great advice John,
    I spent some time yesterday walking through the tests. I think the Saw blade analogy was the most helpful thing for me, it appears that I was using the non CP setting from the NN camera settings page, (Yes, I know, I'm a noob) When I set my camera to the w/Cp setting it just took a few more small adjustments to make my tripod appear completely circular. I had seen some other posts on the forum urging people to find the NPP for their particular set up on their own, but in my excitement I just used the settings that were posted on the settings page and found that I needed a bit more fine tuning.
    Now that I have the kit set up right I will focus on learning to make PTgui sing.

    Thanks again for your time,
    Bill Wunderlich
+ Reply to Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts