assembly question - am I missing something?

Welcome to Nodal Ninja Forum

+ Reply to Thread
Results 1 to 10 of 10

Thread: assembly question - am I missing something?

Share/Bookmark
  1. assembly question - am I missing something?

    #1

    Just received my new NN3 today and just in the process of getting everything together BUT I can't seem to figure out how to secure the vertical arm to the lower arm. It seems so simple but when I turn the lower knob as far as it can go the arm is still really loose and slides around. Yes, I have the vertical arm facing inside. Everything's as per the instructions otherwise.

    Suggestions anybody?
  2. Re: assembly question - am I missing something?

    #2

    Update: I switched the upper rotator tightening knob with the vertical rail knob. The two pieces now fit together snugly without any play. I thought maybe they had been switched by accident at the plant but the two pieces of the vertical rail do not line up parallel in the "put-away" position.

    I noticed there were two rubber spacers in the kit. If I cut one, I could get the pano head to work with the original knobs in the original place. Is this kind of tweaking normal for the NN3?
  3. Re: assembly question - am I missing something?

    #3
    Users Country Flag
    Join Date: Apr 2008
    Location: Hong Kong
    Posts: 2,364

    Quote Originally Posted by rebecca View Post
    Update: I switched the upper rotator tightening knob with the vertical rail knob. The two pieces now fit together snugly without any play. I thought maybe they had been switched by accident at the plant but the two pieces of the vertical rail do not line up parallel in the "put-away" position.

    I noticed there were two rubber spacers in the kit. If I cut one, I could get the pano head to work with the original knobs in the original place. Is this kind of tweaking normal for the NN3?
    Hi rebecca,
    your NN3 may be defective. Contact your seller for direct support. Actually you get quicker answer by contacting your seller directly.

    nick



    Fanotec
    We listen. We try harder.
  4. Re: assembly question - am I missing something?

    #4

    Rebecca

    I emailed you this morning. I'm currently on the road but have access to the web from time to time. You can let me know of your decision here or reply to my email.

    As I mentioned on the email DO NOT cut the "rubber" spacers. These were the original camera plates. Some still prefer these.

    Have a look inside the bottom of the vertical rail. Make sure there are no foreign objects inside preventing the screw from fully inserting.


    Rosauro

  5. Re: assembly question - am I missing something?

    #5

    Rebecca

    As promised, your replacement NN3 MKII will arrive early Monday. Between 9 to 12 at your requested destination.


    Cheers

    Rosauro
  6. Re: assembly question - am I missing something?

    #6

    This is why I love these guys. Where else in the world can you get customer service like this?
  7. Re: assembly question - am I missing something?

    #7

    Quote Originally Posted by Rosauro View Post
    Rebecca
    As promised, your replacement NN3 MKII will arrive early Monday. Between 9 to 12 at your requested destination.
    Cheers Rosauro
    Thanks Rosauro for being on top of this
    Bill
  8. Re: assembly question - am I missing something?

    #8

    Thanks chuxter.

    No problem Bill. Rebecca too is an awesome customer. She sent the unit right away. I received it today.


    Rosauro
  9. Re: assembly question - am I missing something?

    #9

    Join Date: May 2008
    Location: sunshine coast
    Posts: 21

    gota love good service way to go =]
  10. Re: assembly question - am I missing something?

    #10

    Being a small company allows us to provide a more personal service which we pride ourselves with.
+ Reply to Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts