Announcement

Collapse
No announcement yet.

NN3 Mk 2 Upper arm slipping down (Newbie)

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • #16
    Re: NN3 Mk 2 Upper arm slipping down (Newbie)

    I have the same slipping problem. I'm using a 400d w/ Canon 10-22mm mounted on a NN3 MkII w/ RD16. I'll try the two methods described here: 1. washer method and then 2. cleaning method. I'll post my test results here.

    Comment


    • #17
      Re: NN3 Mk 2 Upper arm slipping down (Newbie)

      Originally posted by ruel941 View Post
      I have the same slipping problem. I'm using a 400d w/ Canon 10-22mm mounted on a NN3 MkII w/ RD16. I'll try the two methods described here: 1. washer method and then 2. cleaning method. I'll post my test results here.
      BTW, when you observe the slipping problem, are you using a remote cord to trigger the shutter?


      Nick
      Fanotec
      We listen. We try harder.

      Comment


      • #18
        Re: NN3 Mk 2 Upper arm slipping down (Newbie)

        Originally posted by nick fan View Post
        BTW, when you observe the slipping problem, are you using a remote cord to trigger the shutter?


        Nick
        yes, i always do. but not to the point of dragging the body downwards.

        Comment


        • #19
          Re: NN3 Mk 2 Upper arm slipping down (Newbie)

          cleaning the nn3's washers and the nn3 itself plus adding another washer solved the problem for me. so far so good.

          Comment

          Working...
          X