Announcement

Collapse
No announcement yet.

Help: R10 Set up for Sigma 8mm Fisheye Lens

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • Help: R10 Set up for Sigma 8mm Fisheye Lens

    I have just set up the R10 on my Sigma 8mm fisheye lens for a Canon 7D. Once the outer lens ring is in place the only way to get the lens onto the camera is to loosen the ring, swing the tightening screw out of the way so the lens will screw into place. Then I swing it back around and tighten the ring again. Am I doing this right??? Seems a little clumsy to me. Any help is appreciated.

  • #2
    Is your camera in portrait mode?
    here is the installation guide for the ring
    http://www.nodalninja.com/Manuals/QR..._18Oct2014.pdf
    http://www.nodalninja.com/Manuals/QR...%20Package.pdf
    Fanotec
    We listen. We try harder.

    Comment


    • #3
      Hello Karen,

      I see Nick has provided you with links to the manuals so hopefully you will be up and running.

      I would recommend fitting the lens ring to the lens then leaving it permanently installed.

      If you are looking for the set up for the NPP (No Parallax Point) / Entrance Pupil then this page may help;
      http://www.hugh360.co.uk/measurement...int-of-a-lens/

      Hope this helps, Hugh.

      Comment


      • #4
        Thanks for the links. I have the mount on the lens. That part is fine. I just find that when I go to the put the lens onto the camera the lens ring is in the way (it won't move past the pop up flash on my 7 D) so I have to loosen the lens ring and swing it out of the way, attach the lens to the camera, then swing the ring back in place and tighten it back up. Is this accepted practice or have I done something wrong?

        Comment


        • #5
          Hello Karen,

          I think I now understand your situation.

          I use Nikon cameras, but there should not be any difference.

          The lens ring should be fitted to the Sigma 8 mm so that the hand grip is opposite to the foot that fits to the R10 so that when the camera is on the R10 the camera is in portrait orientation with the pop up flash to the left as in the top left photo on:
          http://www.nodalninja.com/Manuals/QR..._18Oct2014.pdf
          With this agangement there should be no conflict between the lens ring and the camera.

          If you are still have problems can you post a photo of your arrangement,

          Comment


          • #6
            Hi Hugh,
            Thanks for the reply. I think I solved the issue. I initially had the ring set too far back on the lens. I have taken some pics of my set up for you to check out. I bought the kit second hand and it was already set up for the canon camera.The only thing I am worried about is the positioning of the silver screw. Your instruction state it should be in the middle hole, however it did nt come to me that way and I can't get the .85 setting if it is not in the rear position. Anyhow check outlay set up and let me know what you think. I have a shoot Friday and want to get it right!
            (FYI this is the only photo that will upload.)

            Comment


            • #7
              Here is one more. Hope the file size is not too small to see clearly.
              Thanks KB

              Comment


              • #8
                Hello Helen,

                Looking at the photos it appears that the lens ring is now correctly fitted.

                When fitting the ring you should be able to feel the inner ring "clip" into place as the raised ring on the lens fits into the grove round the inner ring.
                The ring is correctly fitted when turning the lens around the vertical axis the line of the vertical axis passes through the NPP which is at the gold ring or a little in front (away from the camera) of it (say 1 mm or 2 mm) for the Sigma 8 mm lens.
                This is not too critical unless you wish to make panoramas of subjects very close to the camera, such as inside a car.
                I use the Sigma 8 mm set up at the gold ring with great results.

                It is worth noting that the position of the lens on the R10 depends on the lens and not the camera and it is quite possible that the kit may not have been set up correctly by the previous owner.

                From what I can see from the photos the lens ring no longer conflicts with the camera, which is how it should be.
                It should never be necessary to unclamp the ring to fit the lens to the camera and advisable to leave the lens ring in place once fitted.

                Comment

                Working...
                X