Announcement

Collapse
No announcement yet.

NN3 and lens problem

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • NN3 and lens problem

    I have a Canon 400d ( rebel XTi ) and a Sigma 10-20mm lens, I cant mount the lens on the top arm at the spacing recommended i.e between 93 and 99 depending on focal length. because the lip for the lens hits the Nodal Ninja arm and the lens ring (to change the focal length) also presses against the side of the arm

    please see the photo attached to explain

    Any suggestions on what I need to do to get round this problem ?

    Thanks for any help offered

    Tony

  • #2
    Re: NN3 and lens problem

    Hi Tony,

    Welcome to the NN forums.

    You might consider using the N-CP1 Camera Mounting Plate which provides more clearance between your camera body and NN3 rail.

    Check this page for info...
    http://nodalninja.com/order_nodal_ninja_3.html

    David

    Comment


    • #3
      Re: NN3 and lens problem

      Thanks Macro

      Its very annoying that after spending a lot of money on this kit, you then need to buy extras before you can use it !! >


      Tony

      Comment


      • #4
        Re: NN3 and lens problem

        Hi Tony,
        Welcome.
        Marco is right - you do need the Camera Mounting plate (N-CP1) with this lens. You could also use the t-20 t-adapter but I believe the CP to be a better choice. Do NOT mount and use the camera/lens as you have shown in the image - you might damage your lens.
        Touch bases with me off site - bill[at]nodalninja[dot]com. I have a used t-adapter I can offer you for free.
        Bill

        Comment


        • #5
          Re: NN3 and lens problem

          Thanks Bill I would really appreciate that

          I have sent you an email off line

          Tony

          Comment

          Working...
          X