PDA

View Full Version : Problem with Canon 16-35 + 5D and NNJ5



quillerpl
12-08-2009, 07:48 AM
Hi Everyone!

I have been using NNJ5 for some time now with Canon 5d + 17-40 f/4 set and everything was just perfect. Recently I have bought Canon 16-35 f/2,8 and I did several pano shots with the setting form this website i.e A=53 and B=118.
The problem came up to light during stitching, there are shifts in between particular shots. I have tried PtGui, AutopanoPro and Panorama Factory and they all produced the same effect. At the same time I didn't have any problems with my 17-40 lens.
Strange thing is that the problem seems to appear only at the top part of the photo. Here is an example of what I am trying to describe:
http://www.pbase.com/image/120113374

As you can see there are a lot of close and distant objects on the photo and they are all aligned/overlapped but at the top there is shifting problem. I have tried with different settings of upper arm... I moved it towards front and back without any improvement.

Do you have any idea, what is wrong. Maybe I am doing something wrong or maybe the lens is broken or with some kind of glass defect.

I would be very grateful how help.

Jack

hindenhaag
12-08-2009, 08:18 AM
Hi Jack,

i think there is no problem with your NNP's or the lenses. It has to do with your control points. You have to add them manually to give help to the programs. This is always the same bad situation that you do not find a single spot on a white wall etc. So try to spray some manual Cps. Time ago John gave the tips to place small stickers on the white wall to stitch and then remove them.

If you like to you could send the photos to give you a helping hand.

Cheers

Heinz

quillerpl
12-12-2009, 07:33 PM
Hi Heinz

Thx a lot for the reply, I have experimented with hand-stitching and the results are not that bad. However I have been thinking, why do I have all these problems which make me use hand-stitch-mode. With my Canon 17-40 properly leveled and set up, I just had to load the photos to PTGui or any other stitching software and the result pops up automatically. I used to shot giga pano with Zeiss 100mm f/2,8 and after finding nodal point everything was simple, all softwares I was using back then were stitching and blending my panoramas seamlessly.
I believe that hand-stitching can be a big fun for some people but I really enjoy the final result therefore I am wondering why the automatic mode doesn't work for 16-35 but works fine with 17-40.

Anyway, thank you for hint. I will go and practice with adding some control points.

Cheers
Jack

John Houghton
12-13-2009, 01:12 AM
The distortion in some lenses is more difficult to correct than others and having a good spread of control points is then more critical to enable the optimizer to evaluate the lens correction parameters accurately. If the automatically generated control points are bunched in the middle of the seams for whatever reason, you may need to assign additional points to improve the spread. If you have a good set of lens parameters for the particular focal length you are using, then these can be entered into the project (either manually or via a template or the lens database). Then you will need fewer control points and their spread will not be so important, but you must take care not to include the lens parameters in the optimization process (in advanced mode).

John

YvesG
12-14-2009, 03:04 PM
I can confirm this.
I shot with my Canon 16-35mm last week and the stitching process has been difficult on autopano.